Back to overview
Resolved

Overseerr items load issue

Jun 27, 2025 at 9:18am UTC
Affected services
Plex

Resolved
Jun 27, 2025 at 9:18am UTC

Overseerr won’t load several items upon opening the app due to API limits from TMDB database. We’re currently investigating & working on a fix.